Sage 50 Slow/Error Prone to Record Update
Sage 50 uses flat-file data files designed in the 1980s. Data files which are not regularly compressed and re-indexed can become slow and error prone, especially when a lot of data is being changed in one process.
Compress and Re-index Data
When records are deleted in Sage 50 they are marked as deleted but not removed. Re-indexing removes the deleted data, which may explain why updates have become slow.
Optionally delete old Sage 50 data.
To re-index and compress your data:
- Get everyone out of the Sage 50 company in question.
- Take a backup.
- Log in to Sage 50 and select File > Maintenance.
- Press Compress Data to remove unused space.
- Press the ReIndex button.

- Press Select All, then OK.
- When prompted, compress the data file to remove deleted records and improve efficiency.
Other Factors
If this fails to speed up data updates, network congestion or Wi-Fi can cause degraded performance. If possible, back up the network data, restore it to a local drive, perform major updates, then back up and restore it to the network installation.
